Ez a bővítmény nem lett tesztelve a WordPress legutóbbi 3 fő kiadásával. Lehetséges, hogy már nincs karbantartva, frissítve és a használata gondot jelenthet a frissebb WordPress verziókkal.

Restrict Multisite Plugins

Leírás

A quick adaptation of the theme restriction code for plugins. Can only restrict on a site-wide basis, though it will only affect those sites on which it’s activated. Does not restrict super admins. Plugins must be active on the main site to be controlled by this plugin (this is an issue with WordPress’ plugin structure).

See also: Restrict Multisite Widgets

Telepítés

  1. Upload restrict-multisite-plugins.php to /wp-content/plugins/ directory
  2. Network Activate the plugin through the ‘Plugins’ menu OR Activate the plugin through the ‘Plugins’ menu of every WordPress site you wish to restrict
  3. Select plugins to make available under the ‘Restrictions’ section in the ‘Plugins’ menu in the Network Admin or the ‘Plugins’ section in the ‘Super Admin’ menu

GYIK

Can I enable plugins only for individual sites?

No. You can as a Network Admin however activate plugins for individual sites without restrictions.

Will this plugin affect plugins already activated by site admins?

No. This plugin only prevents changes to the state of plugins and hides them from Admins. You will need to deactivate any plugins manually.

Vélemények

Nincsenek értékelések erről a bővítményről.

Közreműködők és fejlesztők

“Restrict Multisite Plugins” egy nyílt forráskódú szoftver. A bővítményhez a következő személyek járultak hozzá:

Közreműködők

“Restrict Multisite Plugins” fordítása a saját nyelvünkre.

Érdekeltek vagyunk a fejlesztésben?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Változási napló

1.1.3

  • Activation state check for menus to support single blog activation

1.1.2

  • Changed class loading to admin-only

1.1.1

  • Standardised capability used to ‘manage_network_plugins’

1.1

  • Added support for Network Admin
  • Moved page to Network Admin -> Plugins -> Restrictions under WordPress 3.1 and higher
  • Hid Network plugins
  • Changed plugin class to static callbacks

1.0

  • First public release